iOS SDK looses connection to Ricoh while downloading image from it.

The place to discuss development topics.
Discussions on the RICOH THETA API and SDK, image processing of spherical images, other hardware related topics, introduction of useful libraries, etc.

iOS SDK looses connection to Ricoh while downloading image from it.

Postby IonRod » 12 Aug 2015, 11:05

Hello!
I'm trying to create an iOS application for Ricoh Theta.
I've implemented connection to Ricoh, taking image, loading image list, etc. Everything works fine but got one important problem.
When I'm trying to download the image from it (no difference what: fullsized, thumbnail or resized version) Ricoh and my app looses connection:
1. The result of getResizedImageObject (and other similar functions) is NO, but sometimes is YES (and image is downloaded).
2. In most cases the connection lost after some of the data been downloaded. In that case the WiFi led on Ricoh turns from flashing blue into red (not flashing)
3. After trying to download a couple of times it works as expected and image is download.

I've tested example app, on some iPhones it has the same problem while on the others is not and it works fine.

Seems like the problem does not connected to iPhone/iOS version as I've tested it on iPad Mini/iPhone 5/iPhone 6+ with iOs 7 and 8. (Not sure about iOS minor version).

Is anyone have faced with the same problem or maybe you know what can cause it?
IonRod
 
Posts: 12
Joined: 02 May 2015, 15:17

Return to Development



All times are UTC